Resolved
The issue has been resolved and invitation links now work correctly for all new users.
If you continue to experience any issues, please reach out to support@entropia.io.
Identified
We've identified the issue causing email invitation links to fail for new users only.
Our team has identified the root cause and a fix is currently being deployed. We'll provide another update once the fix is live.
Investigating
We're investigating reports of users receiving an "invalid link" error when opening email invitation links. We'll provide updates as we learn more.